VULNERABILITY INTELLIGENCE
CVE-2026-81719
CVSS score7.8 HIGH
EPSS probability0.44%
CISA KEVNot currently listed
Published2026-08-27
Last modified2026-09-02
CVSS vectorCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Description
openssl_encrypt before 1.4.9 executes untrusted third-party plugins with insufficient controls: the plugin signature policy defaulted to WARN, so an unsigned/unverifiable non-built-in plugin was compiled and executed in the host process at import time, before the runtime sandbox is installed. The only default gate was an incomplete, bypassable AST denylist. If a user is induced to load an attacker's plugin, this results in arbitrary code execution with the privileges of the user running openssl_encrypt. Fixed in 1.4.9 by defaulting the signature policy to ENFORCE for non-built-in plugins.
Weakness classification
- disclosure@vulncheck.com: CWE-94
Primary references
- disclosure@vulncheck.com — Vendor Advisory
- disclosure@vulncheck.com — Third Party Advisory