VULNERABILITY INTELLIGENCE
CVE-2026-66422
CVSS score8.1 HIGH
EPSS probability0.43%
CISA KEVNot currently listed
Published2026-08-25
Last modified2026-08-27
CVSS vectorCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:H
Description
Improper Authorization vulnerability in Apache Tomcat cause by security-role-ref definitions being incorrectly used as role aliases within the Realm in additional to the correct usage with Request.isUserInRole(). This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.24, from 10.1.0-M1 through 10.1.57, from 9.0.25 through 9.0.120. The following versions were EOL at the time the CVE was created but are known to be affected: from 8.5.46 through 8.5.100, from 7.0.97 through 7.0.109. Other unsupported versions may also be affected. Users are recommended to upgrade to version 11.0.25, 10.1.58 or 9.0.121, which fix the issue.
Weakness classification
- security@apache.org: CWE-285
Primary references
- security@apache.org — Vendor Advisory, Mailing List
- af854a3a-2127-422b-91ae-364da2661108 — Third Party Advisory, Mailing List