VULNERABILITY INTELLIGENCE
CVE-2026-59799
CVSS score8.8 HIGH
EPSS probability0.60%
CISA KEVNot currently listed
Published2026-08-21
Last modified2026-10-16
CVSS vectorCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Description
Improper Privilege Management vulnerability in Apache CloudStack's Two-factor authentication plugin allowing bypass of the two-factor authentication disable flow. This issue affects Apache CloudStack: from 4.18.0.0 through 4.20.3.0 and from 4.21.0.0 through 4.22.1.0. Users are recommended to upgrade to version 4.20.3.1 or 4.22.1.1 or later, which fixes the issue.
Weakness classification
- security@apache.org: CWE-269
Primary references
- security@apache.org — Mailing List, Vendor Advisory