VULNERABILITY INTELLIGENCE
CVE-2026-49872
CVSS score8.1 HIGH
EPSS probability0.53%
CISA KEVNot currently listed
Published2026-06-19
Last modified2026-10-26
CVSS vectorCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N
Description
Improper Authentication vulnerability in Apache APISIX. When the cas-auth plugin is used in a route, an attacker can possibly authenticate itself with credentials from a different source. This issue affects Apache APISIX: from 3.0.0 through 3.16.0. Users are recommended to upgrade to version 3.17.0, which fixes the issue.
Weakness classification
- security@apache.org: CWE-287
Primary references
- security@apache.org — Vendor Advisory, Mailing List
- af854a3a-2127-422b-91ae-364da2661108 — Third Party Advisory