VULNERABILITY INTELLIGENCE

CVE-2026-49871

CVSS score9.3 CRITICAL
EPSS probability0.35%
CISA KEVNot currently listed
Published2026-06-19
Last modified2026-10-26
CVSS vectorCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:N

Description

Cross-Site Request Forgery (CSRF) vulnerability in the cas-auth plugin under default configurations. This defect allows a remote attacker that manages to send a victim to a webpage controlled by them can cause the victim's browser to become authenticated as a different identity. Actions the victim takes upstream are then attributed to attackers identity. This issue affects Apache APISIX: from 3.0.0 through 3.16.0. Users are recommended to upgrade to version 3.17.0, which fixes the issue.

Weakness classification

  • security@apache.org: CWE-352

Primary references