VULNERABILITY INTELLIGENCE
CVE-2026-49434
CVSS score7.5 HIGH
EPSS probability0.63%
CISA KEVNot currently listed
Published2026-06-30
Last modified2026-07-02
CVSS vectorCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
Description
Improper Input Validation vulnerability in Apache ActiveMQ Broker, Apache ActiveMQ, Apache ActiveMQ All. An attacker that has access to publish or modify entries in LDAP that match the configured searchBase and searchFilter can instantiate denied transports inside the broker JVM. This can be used to fetch an attacker URL and spawn a second BrokerService inside the same JVM. This issue affects Apache ActiveMQ Broker: before 5.19.8, from 6.0.0 before 6.2.7; Apache ActiveMQ: before 5.19.8, from 6.0.0 before 6.2.7; Apache ActiveMQ All: before 5.19.8, from 6.0.0 before 6.2.7. Users are recommended to upgrade to version 6.2.7 or 5.19.8, which fixes the issue.
Weakness classification
- security@apache.org: CWE-20
Primary references
- security@apache.org — Vendor Advisory
- af854a3a-2127-422b-91ae-364da2661108 — Third Party Advisory