VULNERABILITY INTELLIGENCE
CVE-2026-49231
CVSS score5.4 MEDIUM
EPSS probability0.57%
CISA KEVNot currently listed
Published2026-06-19
Last modified2026-10-26
CVSS vectorCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N
Description
Authentication Bypass by Spoofing vulnerability in opa plugin. An attacker could relay spoofed identity headers to upstream capitalising on non-default configuration in opa plugin. This could allow the attacker to assume higher privileges on the upstream service. This issue affects Apache APISIX: from 3.5.0 through 3.16.0. Users are recommended to upgrade to version 3.17.0, which fixes the issue.
Weakness classification
- security@apache.org: CWE-290
Primary references
- security@apache.org — Vendor Advisory, Mailing List
- af854a3a-2127-422b-91ae-364da2661108 — Third Party Advisory