VULNERABILITY INTELLIGENCE
CVE-2026-49230
CVSS score6.3 MEDIUM
EPSS probability0.30%
CISA KEVNot currently listed
Published2026-06-19
Last modified2026-10-25
CVSS vectorCVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N
Description
Improper Validation of Integrity Check Value vulnerability in Apache APISIX. The jwe-decrypt plugin under default configuration is vulnerable to authentication bypass. This issue affects Apache APISIX: from 3.8.0 through 3.16.0. Users are recommended to upgrade to version 3.17.0, which fixes the issue.
Weakness classification
- CWE-354: Improper Validation of Integrity Check Value
Primary references
- security@apache.org — Vendor Advisory, Mailing List
- af854a3a-2127-422b-91ae-364da2661108 — Third Party Advisory