VULNERABILITY INTELLIGENCE

CVE-2026-49042

CVSS score7.3 HIGH
EPSS probability0.69%
CISA KEVNot currently listed
Published2026-07-06
Last modified2026-10-25
CVSS vectorCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

Description

Improper Input Validation vulnerability in Apache Camel. This issue affects Apache Camel: from 4.8.0 through 4.18.2, from 4.19.0 through 4.20.0. Users are recommended to upgrade to version 4.18.3, 4.21.0, which fixes the issue.

Weakness classification

  • CWE-20: Improper Input Validation

Primary references