VULNERABILITY INTELLIGENCE

CVE-2026-47339

CVSS score8.1 HIGH
EPSS probability0.47%
CISA KEVNot currently listed
Published2026-06-19
Last modified2026-10-26
CVSS vectorCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N

Description

Incorrect Authorization vulnerability in Apache APISIX. An attacker can capitalise on authz-casdoor plugin under default configuration to authenticate themselves with credentials from a different source. This issue affects Apache APISIX: from 2.14.1 through 3.16.0. Users are recommended to upgrade to version 3.17.0, which fixes the issue.

Weakness classification

  • security@apache.org: CWE-863

Primary references