VULNERABILITY INTELLIGENCE
CVE-2026-46588
CVSS score7.3 HIGH
EPSS probability0.69%
CISA KEVNot currently listed
Published2026-07-06
Last modified2026-10-25
CVSS vectorCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
Description
Improper Input Validation vulnerability in Apache Camel. This issue affects Apache Camel: through 4.14.7, from 4.15.0 through 4.18.2, from 4.19.0 through 4.20.0. Users are recommended to upgrade to version 4.14.8, 4.18.3, 4.21.0, which fixes the issue.
Weakness classification
- security@apache.org: CWE-20
Primary references
- security@apache.org — Vendor Advisory, Patch
- af854a3a-2127-422b-91ae-364da2661108 — Third Party Advisory