VULNERABILITY INTELLIGENCE

CVE-2026-42271

CVSS score8.8 HIGH
EPSS probability91.44%
CISA KEVKnown exploited vulnerability
Published2026-05-08
Last modified2026-10-26
CVSS vectorCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Known Exploited Vulnerability

BerriAI LiteLLM Command Injection Vulnerability

Vendor / product: BerriAI / LiteLLM

Description

LiteLLM is a proxy server (AI Gateway) to call LLM APIs in OpenAI (or native) format. From version 1.74.2 to before version 1.83.7, two endpoints used to preview an MCP server before saving it — POST /mcp-rest/test/connection and POST /mcp-rest/test/tools/list — accepted a full server configuration in the request body, including the command, args, and env fields used by the stdio transport. When called with a stdio configuration, the endpoints attempted to connect, which spawned the supplied command as a subprocess on the proxy host with the privileges of the proxy process. The endpoints were gated only by a valid proxy API key, with no role check. Any authenticated user — including holders of low-privilege internal-user keys — could therefore run arbitrary commands on the host. This issue has been patched in version 1.83.7.

Weakness classification

  • security-advisories@github.com: CWE-77
  • 0b0ca135-0b70-47e7-9f44-1890c2a1c46c: CWE-78

Primary references