VULNERABILITY INTELLIGENCE
CVE-2026-41677
CVSS score9.1 CRITICAL
EPSS probability0.29%
CISA KEVNot currently listed
Published2026-04-24
Last modified2026-06-17
CVSS vectorCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:H
Description
rust-openssl provides OpenSSL bindings for the Rust programming language. From 0.9.0 to before 0.10.78, the *_from_pem_callback APIs did not validate the length returned by the user's callback. A password callback that returns a value larger than the buffer it was given can cause some versions of OpenSSL to over-read this buffer. OpenSSL 3.x is not affected by this. This vulnerability is fixed in 0.10.78.
Weakness classification
- security-advisories@github.com: CWE-125
Primary references
- security-advisories@github.com — Vendor Advisory