VULNERABILITY INTELLIGENCE
CVE-2026-41268
CVSS score9.8 CRITICAL
EPSS probability17.44%
CISA KEVNot currently listed
Published2026-04-23
Last modified2026-10-26
CVSS vectorCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Description
Flowise is a drag & drop user interface to build a customized large language model flow. Prior to 3.1.0, Flowise is vulnerable to a critical unauthenticated remote command execution (RCE) vulnerability. It can be exploited via a parameter override bypass using the FILE-STORAGE:: keyword combined with a NODE_OPTIONS environment variable injection. This allows for the execution of arbitrary system commands with root privileges within the containerized Flowise instance, requiring only a single HTTP request and no authentication or knowledge of the instance. This vulnerability is fixed in 3.1.0.
Weakness classification
- security-advisories@github.com: CWE-20
Primary references
- security-advisories@github.com — Exploit, Vendor Advisory
- 134c704f-9b21-4f2e-91b3-4a467353bcc0 — Exploit, Vendor Advisory