VULNERABILITY INTELLIGENCE
CVE-2026-33633
CVSS score7.5 HIGH
EPSS probability0.38%
CISA KEVNot currently listed
Published2026-05-19
Last modified2026-07-24
CVSS vectorCVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H
Description
Kitty is a cross-platform GPU based terminal. Versions 0.46.2 and below contain a heap buffer overflow in load_image_data() that allows any process which can write to the terminal's stdin to crash kitty immediately. The vulnerability is triggered by a single APC graphics protocol command with a PNG format declaration (f=100) whose payload exceeds twice the initial buffer capacity. The overflow is attacker-controlled in both length and content, causing DoS and potentially escalation to RCE itself. This issue has been fixed in version 0.47.0.
Weakness classification
- security-advisories@github.com: CWE-122
Primary references
- security-advisories@github.com — Patch
- security-advisories@github.com — Exploit, Vendor Advisory
- 134c704f-9b21-4f2e-91b3-4a467353bcc0 — Exploit, Vendor Advisory