VULNERABILITY INTELLIGENCE

CVE-2026-31923

CVSS score7.5 HIGH
EPSS probability0.25%
CISA KEVNot currently listed
Published2026-04-14
Last modified2026-10-26
CVSS vectorCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

Description

Cleartext Transmission of Sensitive Information vulnerability in Apache APISIX. This can occur due to `ssl_verify` in openid-connect plugin configuration being set to false by default. This issue affects Apache APISIX: from 0.7 through 3.15.0. Users are recommended to upgrade to version 3.16.0, which fixes the issue.

Weakness classification

  • security@apache.org: CWE-319

Primary references