VULNERABILITY INTELLIGENCE
CVE-2026-2996
CVSS score7.5 HIGH
EPSS probability0.53%
CISA KEVNot currently listed
Published2026-08-22
Last modified2026-10-12
CVSS vectorCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
Description
The Advanced Product Fields (Product Addons) for WooCommerce plugin for WordPress is vulnerable to Improper Input Validation in all versions up to, and including, 1.6.21. This is due to a logic flaw in the 'validate_cart_data' function. This makes it possible for unauthenticated attackers to bypass required paid addons and complete purchases at the base product price only, effectively stealing products by paying a fraction of the intended total. The vulnerability was partially patched in version 1.6.19.
Weakness classification
- security@wordfence.com: CWE-20