VULNERABILITY INTELLIGENCE

CVE-2026-29146

CVSS score7.5 HIGH
EPSS probability8.85%
CISA KEVNot currently listed
Published2026-04-09
Last modified2026-10-26
CVSS vectorCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

Description

Padding Oracle vulnerability in Apache Tomcat's EncryptInterceptor with default configuration. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.18, from 10.0.0-M1 through 10.1.52, from 9.0.13 through 9..115, from 8.5.38 through 8.5.100, from 7.0.100 through 7.0.109. Users are recommended to upgrade to version 11.0.19, 10.1.53 and 9.0.116, which fixes the issue.

Weakness classification

  • 134c704f-9b21-4f2e-91b3-4a467353bcc0: CWE-209
  • 0b0ca135-0b70-47e7-9f44-1890c2a1c46c: CWE-1240

Primary references