VULNERABILITY INTELLIGENCE

CVE-2026-19589

CVSS score7.1 HIGH
EPSS probability0.19%
CISA KEVNot currently listed
Published2026-08-17
Last modified2026-10-23
CVSS vectorCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:C/C:L/I:H/A:N

Description

Packer up to 1.15.4 is vulnerable to an issue in the third-party plugin installer that may allow unintended file system modification and could lead to code execution. A user who installs a plugin from a malicious or compromised source may be affected. This vulnerability (CVE-2026-19589) is fixed in Packer 1.16.0.

Weakness classification

  • CWE-22: Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal')

Primary references