VULNERABILITY INTELLIGENCE

CVE-2026-12957

CVSS score8.5 HIGH
EPSS probability0.23%
CISA KEVNot currently listed
Published2026-06-23
Last modified2026-10-26
CVSS vectorCVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

Description

Improper trust boundary enforcement in Language Servers for AWS before version 1.65.0 on all supported platforms may allow a for arbitrary code execution. If a local user opens a maliciously crafted workspace, any commands within the project configuration files may be automatically executed. This issue requires the user to trust the workspace when prompted. To remediate this issue, users should upgrade to Language Servers for AWS version 1.65.0 or higher.

Weakness classification

  • CWE-732: Incorrect Permission Assignment for Critical Resource

Primary references