VULNERABILITY INTELLIGENCE

CVE-2025-68145

CVSS score9.1 CRITICAL
EPSS probability7.03%
CISA KEVNot currently listed
Published2025-12-17
Last modified2026-09-30
CVSS vectorCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N

Description

In mcp-server-git versions prior to 2025.12.17, when the server is started with the --repository flag to restrict operations to a specific repository path, it did not validate that repo_path arguments in subsequent tool calls were actually within that configured path. This could allow tool calls to operate on other repositories accessible to the server process. The fix adds path validation that resolves both the configured repository and the requested path (following symlinks) and verifies the requested path is within the allowed repository before executing any git operations. Users are advised to upgrade to 2025.12.17 upon release to remediate this issue.

Weakness classification

  • security-advisories@github.com: CWE-22

Primary references