VULNERABILITY INTELLIGENCE
CVE-2025-66675
CVSS score8.2 HIGH
EPSS probability0.59%
CISA KEVNot currently listed
Published2025-12-10
Last modified2026-10-14
CVSS vectorCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:H
Description
Denial of Service vulnerability in Apache Struts, file leak in multipart request processing causes disk exhaustion. This issue affects Apache Struts: from 2.0.0 through 6.7.4, from 7.0.0 through 7.0.3. Users are recommended to upgrade to version 6.8.0 or 7.1.1, which fixes the issue. It's related to https://cve.org/CVERecord?id=CVE-2025-64775 - this CVE addresses missing affected version 6.7.4
Weakness classification
- security@apache.org: CWE-459
Primary references
- security@apache.org — Third Party Advisory
- security@apache.org — Vendor Advisory