VULNERABILITY INTELLIGENCE
CVE-2025-64775
CVSS score7.5 HIGH
EPSS probability1.53%
CISA KEVNot currently listed
Published2025-12-01
Last modified2026-10-18
CVSS vectorCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Description
Denial of Service vulnerability in Apache Struts, file leak in multipart request processing causes disk exhaustion. This issue affects Apache Struts: from 2.0.0 through 6.7.0, from 7.0.0 through 7.0.3. Users are recommended to upgrade to version 6.8.0 or 7.1.1, which fixes the issue.
Weakness classification
- security@apache.org: CWE-459
Primary references
- security@apache.org — Vendor Advisory
- af854a3a-2127-422b-91ae-364da2661108 — Mailing List, Third Party Advisory