VULNERABILITY INTELLIGENCE
CVE-2025-62372
CVSS score8.3 HIGH
EPSS probability0.41%
CISA KEVNot currently listed
Published2025-11-21
Last modified2026-10-19
CVSS vectorCVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:H/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
Description
vLLM is an inference and serving engine for large language models (LLMs). From version 0.5.5 to before 0.11.1, users can crash the vLLM engine serving multimodal models by passing multimodal embedding inputs with correct ndim but incorrect shape (e.g. hidden dimension is wrong), regardless of whether the model is intended to support such inputs (as defined in the Supported Models page). This issue has been patched in version 0.11.1.
Weakness classification
- CWE-129: Improper Validation of Array Index
Primary references
- security-advisories@github.com — Patch
- security-advisories@github.com — Issue Tracking, Patch, Vendor Advisory
- security-advisories@github.com — Issue Tracking
- security-advisories@github.com — Mitigation, Vendor Advisory