VULNERABILITY INTELLIGENCE
CVE-2025-59828
CVSS score9.8 CRITICAL
EPSS probability0.36%
CISA KEVNot currently listed
Published2025-09-24
Last modified2026-06-17
CVSS vectorCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Description
Claude Code is an agentic coding tool. Prior to Claude Code version 1.0.39, when using Claude Code with Yarn versions 2.0+, Yarn plugins are auto-executed when running yarn --version. This could lead to a bypass of the directory trust dialog in Claude Code, as plugins would be executed prior to the user accepting the risks of working in an untrusted directory. Users running Yarn Classic were unaffected by this issue. This issue has been fixed in version 1.0.39. Users on standard Claude Code auto-update will have received this fix automatically. Users performing manual updates are advised to update to the latest version.
Weakness classification
- security-advisories@github.com: CWE-829
Primary references
- security-advisories@github.com — Third Party Advisory