VULNERABILITY INTELLIGENCE

CVE-2025-54572

EPSS probability0.46%
CISA KEVNot currently listed
Published2025-07-30
Last modified2026-06-17

Description

The Ruby SAML library is for implementing the client side of a SAML authorization. In versions 1.18.0 and below, a denial-of-service vulnerability exists in ruby-saml even with the message_max_bytesize setting configured. The vulnerability occurs because the SAML response is validated for Base64 format prior to checking the message size, leading to potential resource exhaustion. This is fixed in version 1.18.1.

Weakness classification

  • security-advisories@github.com: CWE-400

Primary references