VULNERABILITY INTELLIGENCE
CVE-2025-49812
CVSS score7.4 HIGH
EPSS probability0.61%
CISA KEVNot currently listed
Published2025-07-10
Last modified2026-06-17
CVSS vectorCVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N
Description
In some mod_ssl configurations on Apache HTTP Server versions through to 2.4.63, an HTTP desynchronisation attack allows a man-in-the-middle attacker to hijack an HTTP session via a TLS upgrade. Only configurations using "SSLEngine optional" to enable TLS upgrades are affected. Users are recommended to upgrade to version 2.4.64, which removes support for TLS upgrade.
Weakness classification
- CWE-287: Improper Authentication