VULNERABILITY INTELLIGENCE

CVE-2025-48912

CVSS score6.5 MEDIUM
EPSS probability0.79%
CISA KEVNot currently listed
Published2025-05-30
Last modified2026-06-17
CVSS vectorCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N

Description

An authenticated malicious actor using specially crafted requests could bypass row level security configuration by injecting SQL into 'sqlExpression' fields. This allowed the execution of sub-queries to evade parsing defenses ultimately granting unauthorized access to data. This issue affects Apache Superset: before 4.1.2. Users are recommended to upgrade to version 4.1.2, which fixes the issue.

Weakness classification

  • security@apache.org: CWE-89

Primary references