VULNERABILITY INTELLIGENCE
CVE-2025-4102
CVSS score7.2 HIGH
EPSS probability0.61%
CISA KEVNot currently listed
Published2025-06-20
Last modified2026-06-17
CVSS vectorCVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H
Description
The Beaver Builder Plugin (Starter Version) plugin for WordPress is vulnerable to arbitrary file uploads due to missing file type validation in the 'save_enabled_icons' function in all versions up to, and including, 2.9.1. This makes it possible for authenticated attackers, with Administrator-level access and above, to upload arbitrary files on the affected site's server which may make remote code execution possible. The vulnerability was partially patched in version 2.9.1.
Weakness classification
- security@wordfence.com: CWE-434
Primary references
- security@wordfence.com — Third Party Advisory
- security@wordfence.com — Product