VULNERABILITY INTELLIGENCE
CVE-2025-3438
CVSS score6.5 MEDIUM
EPSS probability0.34%
CISA KEVNot currently listed
Published2025-05-02
Last modified2026-06-17
CVSS vectorCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N
Description
The MStore API – Create Native Android & iOS Apps On The Cloud plugin for WordPress is vulnerable to limited privilege escalation in all versions up to, and including, 4.17.4. This is due to a lack of restriction of role when registering. This makes it possible for unauthenticated attackers to to register with the 'wcfm_vendor' role, which is a Store Vendor role in the WCFM Marketplace – Multivendor Marketplace for WooCommerce plugin for WordPress. The vulnerability can only be exploited if the WCFM Marketplace – Multivendor Marketplace for WooCommerce plugin is installed and activated. The vulnerability was partially patched in version 4.17.3.
Weakness classification
- security@wordfence.com: CWE-269
- nvd@nist.gov: NVD-CWE-noinfo
Primary references
- security@wordfence.com — Product
- security@wordfence.com — Product
- security@wordfence.com — Patch
- security@wordfence.com — Patch
- security@wordfence.com — Third Party Advisory