VULNERABILITY INTELLIGENCE

CVE-2025-29927

CVSS score9.1 CRITICAL
EPSS probability99.22%
CISA KEVNot currently listed
Published2025-03-21
Last modified2026-06-17
CVSS vectorCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N

Description

Next.js is a React framework for building full-stack web applications. Starting in version 1.11.4 and prior to versions 12.3.5, 13.5.9, 14.2.25, and 15.2.3, it is possible to bypass authorization checks within a Next.js application, if the authorization check occurs in middleware. If patching to a safe version is infeasible, it is recommend that you prevent external user requests which contain the x-middleware-subrequest header from reaching your Next.js application. This vulnerability is fixed in 12.3.5, 13.5.9, 14.2.25, and 15.2.3.

Weakness classification

  • security-advisories@github.com: CWE-285
  • nvd@nist.gov: CWE-863

Primary references