VULNERABILITY INTELLIGENCE
CVE-2025-24854
CVSS score6.1 MEDIUM
EPSS probability0.51%
CISA KEVNot currently listed
Published2025-07-31
Last modified2026-06-17
CVSS vectorCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Description
A carefully crafted request using the Image plugin could trigger an XSS vulnerability on Apache JSPWiki, which could allow the attacker to execute javascript in the victim's browser and get some sensitive information about the victim. Apache JSPWiki users should upgrade to 2.12.3 or later.
Weakness classification
- security@apache.org: CWE-79
Primary references
- security@apache.org — Vendor Advisory
- af854a3a-2127-422b-91ae-364da2661108