VULNERABILITY INTELLIGENCE

CVE-2025-0914

CVSS score3.8 LOW
EPSS probability0.23%
CISA KEVNot currently listed
Published2025-02-27
Last modified2026-06-17
CVSS vectorCVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:L/I:L/A:N

Description

An improper access control issue in the VQL shell feature in Velociraptor Versions < 0.73.4 allowed authenticated users to execute the execve() plugin in deployments where this was explicitly forbidden by configuring the prevent_execve flag in the configuration file. This setting is not usually recommended and is uncommonly used, so this issue will only affect users who do set it. This issue is fixed in release 0.73.4.

Weakness classification

  • cve@rapid7.com: CWE-281

Primary references