VULNERABILITY INTELLIGENCE
CVE-2024-6482
CVSS score8.8 HIGH
EPSS probability0.48%
CISA KEVNot currently listed
Published2024-09-14
Last modified2026-06-17
Description
The Login with phone number plugin for WordPress is vulnerable to privilege escalation in all versions up to, and including, 1.7.49. This is due to a lack of validation and missing capability check on user-supplied data in the 'lwp_update_password_action' function. This makes it possible for authenticated attackers, with Subscriber-level access and above, to update their role to any other role, including Administrator. The vulnerability was partially patched in version 1.7.40. The login with phone number pro plugin was required to exploit the vulnerability in versions 1.7.40 - 1.7.49.