VULNERABILITY INTELLIGENCE
CVE-2024-6340
CVSS score6.4 MEDIUM
EPSS probability0.36%
CISA KEVNot currently listed
Published2024-07-03
Last modified2026-06-17
CVSS vectorCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N
Description
The Premium Addons for Elementor plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's Countdown widget in all versions up to, and including, 4.10.36 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. The vulnerability was partially patched in version 4.10.36 and fully patched in version 4.10.37.
Weakness classification
- security@wordfence.com: CWE-79
- nvd@nist.gov: CWE-79
Primary references
- security@wordfence.com — Product
- security@wordfence.com — Product
- security@wordfence.com
- security@wordfence.com — Product, Release Notes
- security@wordfence.com — Third Party Advisory
- af854a3a-2127-422b-91ae-364da2661108 — Product
- af854a3a-2127-422b-91ae-364da2661108 — Product
- af854a3a-2127-422b-91ae-364da2661108 — Patch
- af854a3a-2127-422b-91ae-364da2661108 — Product, Release Notes
- af854a3a-2127-422b-91ae-364da2661108 — Third Party Advisory