VULNERABILITY INTELLIGENCE

CVE-2024-5945

CVSS score6.4 MEDIUM
EPSS probability0.33%
CISA KEVNot currently listed
Published2024-06-21
Last modified2026-06-17
CVSS vectorCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N

Description

The WP SVG Images plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the ‘type’ parameter in all versions up to, and including, 4.3 due to insufficient input sanitization. This makes it possible for authenticated attackers, with Author-level access and above, who have permissions to upload sanitized files, to bypass SVG sanitization and inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. A bypass to the patch in version 4.3 was discovered and fixed completely in version 4.4.

Weakness classification

  • security@wordfence.com: CWE-79
  • nvd@nist.gov: CWE-79

Primary references