VULNERABILITY INTELLIGENCE

CVE-2024-55633

CVSS score6.5 MEDIUM
EPSS probability2.81%
CISA KEVNot currently listed
Published2024-12-12
Last modified2026-06-17
CVSS vectorCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N

Description

Improper Authorization vulnerability in Apache Superset. On Postgres analytic databases an attacker with SQLLab access can craft a specially designed SQL DML statement that is Incorrectly identified as a read-only query, enabling its execution. Non postgres analytics database connections and postgres analytics database connections set with a readonly user (advised) are not vulnerable.  This issue affects Apache Superset: before 4.1.0. Users are recommended to upgrade to version 4.1.0, which fixes the issue.

Weakness classification

  • security@apache.org: CWE-863
  • nvd@nist.gov: CWE-863

Primary references