VULNERABILITY INTELLIGENCE

CVE-2024-53949

CVSS score6.5 MEDIUM
EPSS probability0.72%
CISA KEVNot currently listed
Published2024-12-09
Last modified2026-06-17
CVSS vectorCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N

Description

Improper Authorization vulnerability in Apache Superset when FAB_ADD_SECURITY_API is enabled (disabled by default). Allows for lower privilege users to use this API.  issue affects Apache Superset: from 2.0.0 before 4.1.0. Users are recommended to upgrade to version 4.1.0, which fixes the issue.

Weakness classification

  • security@apache.org: CWE-863
  • nvd@nist.gov: CWE-863

Primary references