VULNERABILITY INTELLIGENCE
CVE-2024-51567
CVSS score10 CRITICAL
EPSS probability84.40%
CISA KEVKnown exploited vulnerability
Published2024-10-29
Last modified2026-08-04
CVSS vectorCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H
Known Exploited Vulnerability
CyberPanel Incorrect Default Permissions Vulnerability
Vendor / product: CyberPersons / CyberPanel
Description
upgrademysqlstatus in databases/views.py in CyberPanel (aka Cyber Panel) before 5b08cd6 allows remote attackers to bypass authentication and execute arbitrary commands via /dataBases/upgrademysqlstatus by bypassing secMiddleware (which is only for a POST request) and using shell metacharacters in the statusfile property, as exploited in the wild in October 2024 by PSAUX. Versions through 2.3.6 and (unpatched) 2.3.7 are affected.
Weakness classification
- nvd@nist.gov: CWE-306
- 134c704f-9b21-4f2e-91b3-4a467353bcc0: CWE-306
Primary references
- cve@mitre.org — Technical Description
- cve@mitre.org — Technical Description
- cve@mitre.org — Release Notes
- cve@mitre.org — Product
- cve@mitre.org — Exploit, Patch
- cve@mitre.org — Patch
- cve@mitre.org — Press/Media Coverage
- 134c704f-9b21-4f2e-91b3-4a467353bcc0 — US Government Resource