VULNERABILITY INTELLIGENCE
CVE-2024-5130
CVSS score7.5 HIGH
EPSS probability0.48%
CISA KEVNot currently listed
Published2024-06-06
Last modified2026-06-17
CVSS vectorCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
Description
An Incorrect Authorization vulnerability exists in lunary-ai/lunary versions up to and including 1.2.2, which allows unauthenticated users to delete any dataset. The vulnerability is due to the lack of proper authorization checks in the dataset deletion endpoint. Specifically, the endpoint does not verify if the provided project ID belongs to the current user, thereby allowing any dataset to be deleted without proper authentication. This issue was fixed in version 1.2.8.
Weakness classification
- security@huntr.dev: CWE-862
- nvd@nist.gov: CWE-639
Primary references
- security@huntr.dev — Patch
- security@huntr.dev — Exploit, Issue Tracking, Patch, Third Party Advisory
- af854a3a-2127-422b-91ae-364da2661108 — Patch
- af854a3a-2127-422b-91ae-364da2661108 — Exploit, Issue Tracking, Patch, Third Party Advisory