VULNERABILITY INTELLIGENCE
CVE-2024-47249
CVSS score5 MEDIUM
EPSS probability0.62%
CISA KEVNot currently listed
Published2024-11-26
Last modified2026-06-17
CVSS vectorCVSS:3.1/AV:A/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:L
Description
Improper Validation of Array Index vulnerability in Apache NimBLE. Lack of input validation for HCI events from controller could result in out-of-bound memory corruption and crash. This issue requires broken or bogus Bluetooth controller and thus severity is considered low. This issue affects Apache NimBLE: through 1.7.0. Users are recommended to upgrade to version 1.8.0, which fixes the issue.
Weakness classification
- security@apache.org: CWE-129
Primary references
- security@apache.org — Patch
- security@apache.org — Mailing List, Vendor Advisory
- af854a3a-2127-422b-91ae-364da2661108 — Mailing List, Vendor Advisory