VULNERABILITY INTELLIGENCE

CVE-2024-45772

CVSS score5.1 MEDIUM
EPSS probability0.58%
CISA KEVNot currently listed
Published2024-09-30
Last modified2026-06-17
CVSS vectorCVSS:3.1/AV:A/AC:H/PR:H/UI:N/S:C/C:L/I:L/A:L

Description

Deserialization of Untrusted Data vulnerability in Apache Lucene Replicator. This issue affects Apache Lucene's replicator module: from 4.4.0 before 9.12.0. The deprecated org.apache.lucene.replicator.http package is affected. The org.apache.lucene.replicator.nrt package is not affected. Users are recommended to upgrade to version 9.12.0, which fixes the issue. The deserialization can only be triggered if users actively deploy an network-accessible implementation and a corresponding client using a HTTP library that uses the API (e.g., a custom servlet and HTTPClient). Java serialization filters (such as -Djdk.serialFilter='!*' on the commandline) can mitigate the issue on vulnerable versions without impacting functionality.

Weakness classification

  • security@apache.org: CWE-502
  • nvd@nist.gov: CWE-502

Primary references