VULNERABILITY INTELLIGENCE

CVE-2024-45719

CVSS score2.6 LOW
EPSS probability0.26%
CISA KEVNot currently listed
Published2024-11-22
Last modified2026-06-17
CVSS vectorCVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:C/C:L/I:N/A:N

Description

Inadequate Encryption Strength vulnerability in Apache Answer. This issue affects Apache Answer: through 1.4.0. The ids generated using the UUID v1 version are to some extent not secure enough. It can cause the generated token to be predictable. Users are recommended to upgrade to version 1.4.1, which fixes the issue.

Weakness classification

  • CWE-326: Inadequate Encryption Strength

Primary references