VULNERABILITY INTELLIGENCE

CVE-2024-44088

CVSS score6.1 MEDIUM
EPSS probability0.69%
CISA KEVNot currently listed
Published2025-10-14
Last modified2026-06-17
CVSS vectorCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Description

Malicious script injection ('Cross-site Scripting') vulnerability in Apache Geode web-api (REST). This vulnerability allows an attacker that tricks a logged-in user into clicking a specially-crafted link to execute code on the returned page, which could lead to theft of the user's session information and even account takeover. This issue affects Apache Geode: all versions prior to 1.15.2 Users are recommended to upgrade to version 1.15.2, which fixes the issue.

Weakness classification

  • security@apache.org: CWE-79

Primary references