VULNERABILITY INTELLIGENCE
CVE-2024-41937
CVSS score6.1 MEDIUM
EPSS probability1.73%
CISA KEVNot currently listed
Published2024-08-21
Last modified2026-06-17
CVSS vectorCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Description
Apache Airflow, versions before 2.10.0, have a vulnerability that allows the developer of a malicious provider to execute a cross-site scripting attack when clicking on a provider documentation link. This would require the provider to be installed on the web server and the user to click the provider link. Users should upgrade to 2.10.0 or later, which fixes this vulnerability.
Weakness classification
- security@apache.org: CWE-79
Primary references
- security@apache.org — Patch
- security@apache.org — Third Party Advisory
- af854a3a-2127-422b-91ae-364da2661108