VULNERABILITY INTELLIGENCE

CVE-2024-3895

CVSS score8.8 HIGH
EPSS probability0.91%
CISA KEVNot currently listed
Published2024-05-02
Last modified2026-06-17
CVSS vectorCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Description

The WP Datepicker plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on the wpdp_add_new_datepicker_ajax() function in all versions up to, and including, 2.1.0. This makes it possible for authenticated attackers, with subscriber-level access and above, to update arbitrary options that can be used for privilege escalation. This was partially patched in 2.0.9 and 2.1.0, and fully patched in 2.1.1.

Weakness classification

  • security@wordfence.com: CWE-862
  • nvd@nist.gov: CWE-862

Primary references