VULNERABILITY INTELLIGENCE

CVE-2024-35164

CVSS score6.8 MEDIUM
EPSS probability0.52%
CISA KEVNot currently listed
Published2025-07-02
Last modified2026-06-17
CVSS vectorCVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:N

Description

The terminal emulator of Apache Guacamole 1.5.5 and older does not properly validate console codes received from servers via text-based protocols like SSH. If a malicious user has access to a text-based connection, a specially-crafted sequence of console codes could allow arbitrary code to be executed with the privileges of the running guacd process. Users are recommended to upgrade to version 1.6.0, which fixes this issue.

Weakness classification

  • security@apache.org: CWE-129
  • nvd@nist.gov: NVD-CWE-noinfo

Primary references