VULNERABILITY INTELLIGENCE
CVE-2024-32638
CVSS score6.3 MEDIUM
EPSS probability1.06%
CISA KEVNot currently listed
Published2024-05-02
Last modified2026-06-17
CVSS vectorCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L
Description
Inconsistent Interpretation of HTTP Requests ('HTTP Request Smuggling') vulnerability in Apache APISIX when using `forward-auth` plugin.This issue affects Apache APISIX: from 3.8.0, 3.9.0. Users are recommended to upgrade to version 3.8.1, 3.9.1 or higher, which fixes the issue.
Weakness classification
- security@apache.org: CWE-444
- 134c704f-9b21-4f2e-91b3-4a467353bcc0: CWE-444
Primary references
- security@apache.org — Mailing List, Third Party Advisory
- security@apache.org — Mailing List, Vendor Advisory
- af854a3a-2127-422b-91ae-364da2661108 — Mailing List, Third Party Advisory
- af854a3a-2127-422b-91ae-364da2661108 — Mailing List, Vendor Advisory