VULNERABILITY INTELLIGENCE

CVE-2024-31866

CVSS score9.8 CRITICAL
EPSS probability1.58%
CISA KEVNot currently listed
Published2024-04-09
Last modified2026-06-17
CVSS vectorCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Description

Improper Encoding or Escaping of Output vulnerability in Apache Zeppelin. The attackers can execute shell scripts or malicious code by overriding configuration like ZEPPELIN_INTP_CLASSPATH_OVERRIDES. This issue affects Apache Zeppelin: from 0.8.2 before 0.11.1. Users are recommended to upgrade to version 0.11.1, which fixes the issue.

Weakness classification

  • security@apache.org: CWE-116

Primary references