VULNERABILITY INTELLIGENCE
CVE-2024-31864
CVSS score9.8 CRITICAL
EPSS probability1.26%
CISA KEVNot currently listed
Published2024-04-09
Last modified2026-06-17
CVSS vectorCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Description
Improper Control of Generation of Code ('Code Injection') vulnerability in Apache Zeppelin. The attacker can inject sensitive configuration or malicious code when connecting MySQL database via JDBC driver. This issue affects Apache Zeppelin: before 0.11.1. Users are recommended to upgrade to version 0.11.1, which fixes the issue.
Weakness classification
- security@apache.org: CWE-94
Primary references
- security@apache.org — Mailing List
- security@apache.org — Issue Tracking
- security@apache.org — Mailing List, Vendor Advisory
- security@apache.org — Not Applicable
- af854a3a-2127-422b-91ae-364da2661108 — Mailing List
- af854a3a-2127-422b-91ae-364da2661108
- af854a3a-2127-422b-91ae-364da2661108 — Issue Tracking
- af854a3a-2127-422b-91ae-364da2661108 — Mailing List, Vendor Advisory
- af854a3a-2127-422b-91ae-364da2661108 — Not Applicable